Plesk Preguntas frecuentes sobre Plesk Onyx

MiddoWeb

Administrador
Staff member
Administrador
Messages
1,524
Reaction score
360
Points
99
Preguntas generales
  • ¿Cuál es la diferencia entre las versiones de Plesk Onyx, como 17.0 y 17.5?
    Estos son lanzamientos menores dentro de Plesk Onyx, que es una versión principal:
    • Plesk Onyx 17.0 se lanzó en noviembre de 2016 y se estabilizó el 15 de marzo de 2017.
    • Plesk Onyx 17.5 fue lanzado el 23 de marzo de 2017.
  • Los cambios en todas las versiones menores de Plesk Onyx se publican en un solo registro de cambios .

  • ¿Puedo actualizar Plesk Onyx Preview a la versión RTM?
    Es técnicamente posible, pero no admitimos oficialmente esta ruta de actualización y, por lo tanto, no podemos garantizar que todo funcionará bien.
  • ¿Cómo puedo instalar Multi Server?
    Plesk Multi Server ha sido lanzado oficialmente y se puede instalar de acuerdo con las instrucciones de instalación .
  • ¿Cambiarán los nombres de las licencias para incluir a Onyx?
    Hay dos maneras en que los nombres de las licencias cambiarán:
    • Si es posible eliminar el número de versión de un nombre de licencia sin crear conflicto con otro tipo de licencia, entonces se eliminará, por ejemplo, "Plesk 12 Web Host Edition" se convertirá en "Plesk Web Host Edition".
    • Cuando no sea posible eliminar el número de versión sin chocar con otro tipo de licencia, se agregará "Onyx", por ejemplo, "Plesk 12.x / Onyx".
  • ¿Qué nuevos complementos / funciones se han agregado a la nueva edición de Plesk?
    Estas son las nuevas funciones de pago / limitadas de Plesk Onyx:
    • Soporte remoto de SmarterMail - disponible como una extensión
    • Plesk Cgroups Manager - disponible como una extensión. Requiere una licencia adicional y se puede comprar por separado o como parte de Hosting Pack .
    • Gestión remota de Docker: disponible como una extensión.
    • DNSSEC - disponible como una extensión.
    • Plesk Multi Server - disponible como una extensión.

  • ¿Es posible obtener la contraseña de administrador de Plesk en texto plano?
    Para mejorar la seguridad, la capacidad de recuperar la contraseña del administrador de Plesk se eliminó en Plesk Onyx. En su lugar, ejecute el plesk logincomando en la línea de comandos para generar un enlace de token temporal.
  • ¿Es posible iniciar sesión en Plesk como root / administrador?
    Sí.
  • ¿Durante cuánto tiempo funciona la URL proporcionada por el comando "plesk login"?
    24 horas.
  • ¿Es posible generar varias URL con "inicio de sesión de plesk" y proporcionarlas a diferentes agentes?
    Sí. Pero cada URL será válida solo por 24 horas.
  • ¿Cuándo será compatible Plesk Onyx con Windows Server 2016?
    Plesk ya es compatible con Windows Server 2016. Puede encontrar la lista completa de sistemas operativos compatibles aquí .
  • ¿Es posible asegurar Plesk con Let's Encrypt?
    Sí, es posible. Debe instalar la extensión Let's Encrypt y crear un dominio en Plesk con un nombre que coincida con el nombre de host de su servidor (ya que cada certificado SSL se emite para un nombre de host específico). También puede proteger a Plesk con la extensión del Asesor de seguridad de Plesk.
DNSSEC
  • Las DNSSEC se transfieren a las claves de firma de clave (KSK), que requieren la actualización de los registros de DS por parte del registrador. Sin esta actualización, la zona DNS dejará de resolverse. ¿Hay algún período de gracia después de la renovación de la clave cuando un usuario debe actualizar los registros de DS?
    Cada zona DNS tiene dos KSK con períodos de renovación superpuestos. Por lo tanto, mientras una de las claves caduca y se reinicia, la segunda clave sigue activa hasta el siguiente período de reinversión. Esto le da al propietario del dominio el tiempo suficiente para actualizar los registros de DS en el lado del registrador sin experimentar ningún problema.
  • ¿El propietario del dominio recibirá una notificación sobre la renovación de la clave? ¿Puede el administrador de Plesk personalizar el texto de la notificación?
    La extensión DNSSEC enviará una notificación al propietario del dominio. El texto de la notificación no puede ser personalizado.
  • ¿En qué sistemas operativos está disponible la característica DNSSEC?
    DNSSEC está disponible en Debian 8, Ubuntu 14.04, Ubuntu 16.04, CentOS 7, RedHat Enterprise Linux 7, CloudLinux 7, Virtuozzo Linux 7.
DKIM, SRS
  • ¿Qué servidores de correo soportan DKIM y SRS?
    En Linux: DKIM es compatible con todos los servidores de correo compatibles con Plesk, y SRS solo con Postfix. En Windows: DKIM es compatible con todos los servidores de correo compatibles con Plesk, excepto las versiones MailEnable anteriores a la 9.16, y SRS es compatible con los servidores de correo SmarterMail y IceWarp.
GIT
  • ¿Puede Plesk Onyx acceder a los repositorios privados de Git en GitHub?
    Sí, es posible, pero debe autenticarse con una clave SSH. La autenticación HTTP / HTTPS no es compatible.
  • Actualmente, los repositorios Git alojados en Plesk están protegidos con la contraseña del usuario de FTP. ¿Es posible proporcionar acceso anónimo a un repositorio Git, a-la GitHub?
    No, solo se admiten repositorios privados. El propósito principal del soporte de Git es el despliegue del sitio web y la aplicación web, con el desarrollador llevando sucursales de repositorio específicas al servidor de git y Plesk implementándolas en el sitio web. Sin embargo, si está interesado en una función de este tipo, comparta su opinión sobre plesk.uservoice.com .
  • ¿Es posible cambiar los archivos en httpdocs / y confirmarlos como cambios en un repositorio Git?
    No. Esto se debe a cómo funciona la implementación de Git. El contenido del directorio httpdocs / no es parte de un repositorio, sino una exportación de una rama específica.
  • ¿Hay planes para agregar soporte para otros sistemas de control de versiones (VCS) como SVN, Mercurial, Bazaar, etc.?
    Por el momento, no hay planes para agregar soporte para otros sistemas de control de versiones.
ESTIBADOR
  • ¿Qué sistemas operativos tienen soporte Docker?
    CentOS 7, RedHat Enterprise Linux 7, Debian 8, Ubuntu 14.04 y Ubuntu 16.04.
  • ¿Plesk cuenta el espacio en disco utilizado por los contenedores Docker conectados a través de las Reglas de proxy a un sitio web para el uso del espacio en disco del sitio web?
    No. Dado que solo el administrador de Plesk puede crear contenedores Docker, y los contenedores Docker están muy poco conectados a sitios web, no se tienen en cuenta para el uso del espacio en disco de la suscripción. Una excepción a esto sería cuando un directorio de sitios web se monta en un contenedor de Docker como un volumen, ya que en este caso todos los archivos ubicados en el contenedor se contabilizarán para el uso del espacio en disco del sitio web.
  • ¿Es posible limitar la CPU y la E / S de disco para los contenedores de Docker?
    Actualmente, solo el límite de RAM se implementa a través de la funcionalidad Docker nativa (que se basa en Linux cgroups en el nivel bajo). Siéntase libre de dar su opinión en plesk.uservoice.com .
  • ¿Se aplican los límites de cgroup de nivel de suscripción (CPU, RAM, E / S de disco) a los contenedores de Docker?
    No. Los contenedores Docker son objetos de nivel de administrador, se ejecutan bajo un usuario de sistema separado y no están controlados por límites de suscripción.
    Nota: actualmente, los contenedores de Docker solo pueden ser administrados por el administrador de Plesk, y no por los clientes o revendedores de Plesk.

  • ¿Puedo ejecutar Docker en contenedores Virtuozzo?
    Docker es compatible con los contenedores de Virtuozzo a partir de la Actualización 1 de Virtuozzo 7 Hotfix 1 (7.0.1-686). Es posible ejecutar el servicio Docker en contenedores Virtuozzo 6, pero no se recomienda ni se admite oficialmente.
  • ¿Qué pasará si instalo la extensión Docker en un servidor donde el servicio Docker no es compatible?
    Docker solo permitirá conectar y administrar servicios remotos de Docker.
  • ¿Funcionarán las reglas de proxy de Docker si el servidor Plesk está detrás de NAT?
    Las reglas de proxy se implementan en la configuración del servidor web, por ejemplo, en el sitio web nginx.conf(en /var/www/vhosts/system/$domain/conf/):

    # extensión de la ventana acoplable comienza
    ubicación ~ ^ /. * {
    proxy_pass http://0.0.0.0:9080;
    proxy_set_header Host $ host;
    proxy_set_header X-Real-IP $ remote_addr;
    proxy_set_header X-Forwarded-For $ proxy_add_x_forwarded_for;
    }
    # extensión de la ventana acoplable final


    Las reglas de proxy deberían funcionar bien en servidores detrás de NAT.
  • Para Docker remoto, ¿el servicio Docker también debe ejecutarse en una máquina virtual Plesk?
    No. El servicio Docker puede funcionar de forma independiente, en un servidor sin Plesk Onyx.
  • ¿La extensión del cortafuegos de Plesk respetará las reglas del cortafuegos de Docker?
    No.
RUBY y NODE.JS
  • Cuando Ruby está instalado, Phusion Passenger también está instalado, pero no Bundler. ¿Por qué?
    Bundler trae un compilador, por lo que esta debe ser una decisión explícita de un administrador del servidor.
  • ¿Es posible adjuntar una versión / compilación personalizada de Ruby?
    Sí. Use ruby-build e instale la nueva versión en un subdirectorio dentro de /opt/plesk/ruby/. Luego, use el siguiente comando para registrar la nueva versión en Plesk:

    # plesk sbin rubymng registrar my-version / opt / plesk / ruby / my-version


  • Si algunos componentes / bibliotecas Node.js se instalan globalmente, ¿los detectará npm o los instalará nuevamente en los paquetes de nodos del sitio web?
    Este es un escenario poco común. La mayoría de las veces, solo las utilidades se instalan globalmente, pero no los paquetes. En tal escenario, npm probablemente instalará el componente en el node_packages/directorio en la raíz de la aplicación.
  • Las aplicaciones Node.js y Ruby pueden instalarse en el mismo dominio, lo que provoca conflictos entre ellas. ¿Hay planes para implementar algún tipo de restricción?
    No. Esperamos que aquellos que usan estas funciones tengan la suficiente competencia para evitar tales errores.
  • ¿Ruby en Plesk Onyx es compatible con aplicaciones escritas utilizando marcos que no sean Rails (por ejemplo, Sinatra, Padrino, etc.)?
    Sí. La extensión de Plesk Ruby es compatible con todas las aplicaciones basadas en Rake (es decir, una aplicación que tiene config.ruy Rakefile).
  • ¿Hay planes para mostrar la salida detallada del comando "Instalar en paquete"?
    Debido a limitaciones técnicas, no.
  • Node.js tiene muy poca salida en los registros del servidor web. ¿Por qué?
    Esta es la forma en que el Pasajero trabaja con Node.js. Los errores / resultados se pueden encontrar en el archivo de registro del servidor web principal ( /var/log/httpd/error_logpara Apache y /var/log/nginx/error.logpara nginx).
  • Para implementar la aplicación Ruby / Node.js, necesito cambiar manualmente la raíz del documento del sitio web para que coincida con la raíz del documento de la aplicación (httpdocs / public). ¿Por qué no puede hacerse automáticamente?
    Cambiar la raíz del documento automáticamente podría no ajustarse a todas las aplicaciones / escenarios. Por ahora, no hay planes para automatizar este paso.
  • ¿Existen utilidades Plesk CLI para habilitar / configurar Ruby, Node.js, Docker, Git, etc.?
    Docker tiene la dockerutilidad de línea de comando nativa con capacidades completas que cubren todo lo que puede hacer desde la interfaz de usuario de Plesk (y mucho más). Git se puede administrar a través de Plesk CLI usando la gitutilidad (consulte la guía de CLI para obtener más detalles). Node.js se puede administrar a través de la CLI de Plesk usando la nodejsutilidad (consulte la guía de la CLI para obtener más detalles). Para el resto de las nuevas funciones, actualmente no hay utilidades de la CLI.
  • ¿Hay alguna llamada a la API para nuevas funciones (Docker, Ruby, Node.js, Git)?
    Git se puede administrar mediante llamadas a la API con el uso del gitoperador (consulte la Guía de la API para obtener más información). Node.js se puede administrar a través de llamadas a la API con el uso del nodejsoperador (consulte la Guía de la API para obtener más detalles). Para las características nuevas restantes, no hay API en este momento. Sin embargo, algunas llamadas a la API están planeadas para Docker.
Herramienta de actualización del sistema
  • ¿Por qué no veo ninguna actualización para el paquete?
    De forma predeterminada, la herramienta de actualización del sistema funciona en el modo "actualizaciones seguras". Significa que la herramienta de actualización del sistema considera las actualizaciones solo desde el mismo repositorio (o compatible) desde el cual se instaló el paquete. Por lo tanto, si una actualización está disponible desde un repositorio diferente, la Herramienta de actualización del sistema no la mostrará.
  • ¿Por qué mis paquetes bloqueados han sido actualizados?
    Lo más probable es que esos paquetes fueran requeridos por otros paquetes que se habían actualizado. La herramienta de actualización del sistema intenta verificar estos casos y le avisará cuando bloquee los paquetes. Pero en casos excepcionales (por ejemplo, cuando la actualización tiene dependencias diferentes a las del paquete instalado), la situación aún puede ocurrir.
  • ¿Cómo puedo agregar o eliminar un repositorio de paquetes?
    Esta funcionalidad está ausente en este momento. Pero si tiene un acceso raíz al servidor, puede registrar un repositorio remoto como se hace generalmente para los administradores de paquetes, como yum o apt.
 
Top